Anbefalet, 2020

Redaktørens Valg

Ingen lyd eller lyd i VMWare Fusion Windows 7 / XP-maskine?

Jeg har kørt rundt med Windows 7 i en virtuel maskine i et stykke tid nu, og jeg har for nylig installeret en ny kopi, men løb ind i et problem. Af en eller anden grund var der ingen lyd output fra min Windows 7 virtuelle maskine. Den anden fungerede fint, så det var virkelig mærkeligt. Hvis du ikke får nogen lyd fra din virtuelle Windows-maskine i VMWare Fusion, er der et par fejlfindingstrin du kan tage.

Til sidst fik jeg lyden på min nye Windows 7 VM til at fungere, men det tog lidt at spille rundt, før jeg kunne finde ud af, hvad problemet var. I denne artikel vil jeg gå igennem et par mulige løsninger og forhåbentlig vil en af ​​dem arbejde for dig. Hvis ikke, send en kommentar, og jeg kommer tilbage til dig med lidt hjælp.

Metode 1 - Kontrollér VM-indstillinger

Det første du vil gøre, er at sørge for, at VM'en faktisk har lyd aktiveret. Du kan gøre dette ved at gå til Virtual Machine og derefter klikke på Indstillinger .

Klik på Lydkort i listen over emner under Flytbare enheder :

Sørg for, at kontakten er slået til.

Bemærk, at hvis du ikke engang har lydkortet under Flytbare enheder, skal du klikke på Tilføj enhed i dialogboksen Indstillinger og derefter vælge Lydkort . Så vil det dukke op, og så kan du tænde det. Hvis dette allerede var aktiveret for dig, så er dit problem noget andet, så fortsæt med at læse.

Metode 2 - Rediger VMX-fil

Der er også nogle konfigurationsindstillinger i din VMX-fil relateret til lyd, der kan forårsage problemet. Du kan åbne VMX-filen til din VM ved at gå til Virtual Machine Library og derefter holde nede Option- tasten og højreklikke på VM. Du får se en indstilling til Open Config File i Editor .

Nu skal du kigge efter følgende parametre og sørge for at de findes i filen:

 sound.present = "TRUE" sound.filename = "-1" sound.autodetect = "TRUE" 

Hvis disse parametre ikke er i filen, skal du tilføje dem. Du skal også fjerne følgende parametre, hvis de eksisterer:

 sound.virtualdev = "sb16" sound.virtualdev = "es1371" sound.virtualdev = "hdaudio" 

Gå videre og genstart VM, når du har tjekket alle disse parametre, og forhåbentlig fungerer din lyd nu! Hvis ikke, har du kun en ekstra mulighed tilbage! Fortsæt læsning.

Metode 3 - Opdater lyddriver i VM

Det sidste du kan prøve, er at opdatere lyddriveren fra den virtuelle Windows-maskine. For at gøre dette kan du højreklikke på Denne computer og vælge Administrer . Klik derefter på Enhedshåndtering i venstre rude. Rul ned til lyd-, video- og spilkontroller og højreklik på Creative AudioPCI (ES1371, ES1373) (WDM), hvis du kører Windows XP eller højreklik på High Definition Audio Device .

Gå nu videre og klik på Update Driver Software, og klik derefter på Søg automatisk for opdateret driver software . Gå videre og genstart VM, når føreren er blevet opdateret.

Top